Accueil > Forum > Bricolage > Drone > Au secour, a l'aide.

Au secour, a l'aide.

CedricJollivet CedricJollivet 5 Messages
Bonjour Lobodol,

J'aurai vraiment besoin de tes super conseils, s'il te plait.
Je me présente, je m'appelle Cédric, automaticien de formation, mais qui a complètement changé d'orientation professionnelle .
Tes tutos sont super, merci beaucoup. Tu m'as redonné le gout, et du coup j'ai "fait" un drone, avec tes conseils.
J'aurai 2 questions, stp.

Le signal, de ma radio commande et le récepteur est de 850u..  a 1850u.., alors que je devrai avoir 1000u.. 2000u...
J'utilise une radio Spektrum DX5E et le récepteur un AR500.
Peut'on modifier le code afin de ne pas racheter une nouvelle Radio/ récepteur (qui coute chère)?
Si oui, je t'en remercie infiniment de me le dire ou.

La deuxième questions, On est obligé de mettre le bout de code sur compenser la baisse de batterie, pour le faire démarrer?

Je te remercie d'avance,
Merci beaucoup.
Salutations
lobodol lobodol 688 Messages BIG BOSS
Salut, en principe oui c'est possible d'adapter le code pour qu'il fonctionne avec la plage 850µs-1850µs. Maintenant il va y avoir pas mal de choses à adapter...
Tes ESC fonctionnent aussi avec cette même plage ?
karim karim 3 Messages
Bonjour Lobodol,

J'auais vraiment besoin de ton aide.
Je suis entrain de réaliser un drone , arrivant à l'étape de calibrage des ESC, et en essayant les moteurs, j'ai constaté que tout ces moteurs démarrent au meme temps alors que lorsqu 'ils arrivent à 2000 ms deux arretent normalement alors que les deux autres arretent en retard apres 2 a 3 secondes.

Merci
CedricJollivet CedricJollivet 5 Messages
Salut Lobodol,
Merci bcp pour ta réponse rapide. 

Mes ESC quand je les calibre avec l'Arduino (ton code, merci...), les moteurs tournent des le début du test (1000µs) , jusqu'à la fin (2000µs)...

Et quand je branche mes esc sur le récepteur radio(sans l'Arduino, comme en modélisme). pour faire un calibrage par exemple, mes moteurs tournent bien, mais j'ai rien pour contrôler si ils sont a 100 %, ou a 80% de leur puissance max par exemple.

Je me suis aperçu que ma Radio commande n'envoyé pas  1000µs et 2000µs comme toi, grasse a ton super cour , tuto...

Pour démarrer le drone, on est obligé de faire le circuit, sur le contrôle de batterie ?, car dans ton schéma, il n'est pas dessus …?


Mes esc sont modernes, qq mois…. pas comme ma radiocommande..

J'espère que ma réponse, puisse t'aider.

Merci, beaucoup,

Tous tes commentaires, sont précieux pour moi, j'aimerai trop arriver a le finir ce projet, tu m'as trop donné envie…..

Salutations.
lobodol lobodol 688 Messages BIG BOSS
Dans l'absolu le contrôle de la batterie n'est pas indispensable. C'est un plus.
Comment tu sais que ta radiocommande ne fonctionne pas sur la plage 1000µs-2000µs ?
CedricJollivet CedricJollivet 5 Messages
Merci Lobodol,

Excuses, si j'ai bien compris, je peux laisser le bout de code (Arduino)  sur le contrôle de la batterie, même si je n'ai pas fait le câblage, il n'y aura d'influence sur le démarrage du drone?

J'ai déduit que le problème de démarrage de mon drone était dû aux signaux de mon récepteur radio, car quand je fais ton tuto chap. 6 (4.5.3) , je vois que le max. et mini. des impulsions de mes sticks sont compris Nini environ 852µs et max 1854µs.

Merci de ton aide the BIG BOSS.
lobodol lobodol 688 Messages BIG BOSS
si j'ai bien compris, je peux laisser le bout de code (Arduino)  sur le contrôle de la batterie, même si je n'ai pas fait le câblage, il n'y
aura d'influence sur le démarrage du drone?
Exactement !
CedricJollivet CedricJollivet 5 Messages
Bonjour Lobodol,

Merci pour la réponse,

Alors ça vient vraiment du signal de mon récepteur/radiocommande :(,
Peux tu m'aider, s'il te plait? je t'en serai vraiment reconnaissant, j'ai vraiment hâte de le voir voler…, si non ca va me prendre beaucoup de temps...
Par exemple, en me disant ou je dois changer mes valeurs, s'il te plait.
car juste pour le "START" du drone, chap.8 (2.3), je dois donner à l'Arduino des valeurs comme 1000µs, 1500µs …. pour le démarrer. Alors que j'ai apparemment d'autres valeurs qui arrivent.

Je pédale vraiment stp, j'ai essayé, avant de venir vers toi, de chercher, bien sur en changeant un peu les valeurs dans le code , mais rien ne bouge.

Merci, d'avance.
Vous devez être connecté pour pouvoir répondre à ce sujet.
Utilisation des données

Afin d'améliorer ton expérience utilisateur, nous utilisons des cookies 🍪